A Couple of Radiator ?'s

Discussion in 'Technical' started by Scotty P, Jul 24, 2007.

  1. Scotty P

    Scotty P Member

    Joined:
    Aug 7, 2003
    Messages:
    1,130
    Likes Received:
    0
    Trophy Points:
    93
    Location:
    santa rosa, ca
    Vehicle:
    1970 Maverick
    Trans is always at 160* or so unless I am in a long stall then it will go to 180-190* External only. Just looking to cool the motor a bit. BMC, the car runs great no issues there so I am not sure that "something is not right" except perhaps too small and old of a radiator. Scott
     
  2. scott

    scott Member

    Joined:
    Sep 26, 2002
    Messages:
    1,252
    Likes Received:
    1
    Trophy Points:
    108
    Location:
    new jersey
    Vehicle:
    1970...302 c4 hookers dynamax (for now)
    before you spend all kinds of money on rads, go buy a couple meat thermometers. boil some water on the stove to see if they say the same thing. it has happenned (to many folks on this board) that the temp gauge in guys cars is wrong. so start the engine with the rad cap off and let it warm up. as soon as the t-stat opens, check the water temp by sticking the meat thermometer(s) in the radiator. see if your temp gauge on your car says the same thing. for all you know, your engine temps are fine... just an in-accurate temp gauge in the car.
     
  3. Scotty P

    Scotty P Member

    Joined:
    Aug 7, 2003
    Messages:
    1,130
    Likes Received:
    0
    Trophy Points:
    93
    Location:
    santa rosa, ca
    Vehicle:
    1970 Maverick
    Scott, much to my wifes chagrin, I did just that! Gauge is accurate. (too bad!) Scott
     

Share This Page