Turn signals not working only on passenger side

Discussion in 'General Maverick/Comet' started by Ford Freak, Dec 5, 2022.

  1. Ford Freak

    Ford Freak IG page the_marvelousmaverick -- follow me !

    Joined:
    Oct 27, 2007
    Messages:
    209
    Likes Received:
    15
    Trophy Points:
    60
    Location:
    United States, CALIFORNIA
    Vehicle:
    1972 maverick 2dr 200,c4 ,ac -sold. 1972 Mexican Maverick 302 4 spd - parted out , 1970 maverick v8 swap. 63 Galaxie 500 2dr sedan , 1984 VW Rabbit GTI
    Hello guys , my 1970 maverick
    Passenger turn signals isn’t working

    Drivers works
    The passengers side sounds like it is buzzing.
    Under load the passenger side headlight dims and brightens.

    the car is currently equipped, with digi tails led sequential taillights , side markers led
    Led bulbs in the front parking lights

    the flashers are digi tails led flashers
    Can a failed flasher cause that ?
    I replaced the starter switch since the replacement had a failed ground
    I also added the two bolts in the column since it wasn’t there prior , a “mechanic “ left it
    Out .
     
  2. 71Mavrk

    71Mavrk Member

    Joined:
    Jul 27, 2011
    Messages:
    1,169
    Likes Received:
    398
    Trophy Points:
    238
    Garage:
    1
    Location:
    Nevada
    Vehicle:
    1971 Maverick Grabber Clone, 1971 Maverick project
    Ford Freak likes this.
  3. Ford Freak

    Ford Freak IG page the_marvelousmaverick -- follow me !

    Joined:
    Oct 27, 2007
    Messages:
    209
    Likes Received:
    15
    Trophy Points:
    60
    Location:
    United States, CALIFORNIA
    Vehicle:
    1972 maverick 2dr 200,c4 ,ac -sold. 1972 Mexican Maverick 302 4 spd - parted out , 1970 maverick v8 swap. 63 Galaxie 500 2dr sedan , 1984 VW Rabbit GTI
    Thank you
     

Share This Page